SERVER PROBLEMS.

Message boards : Number crunching : SERVER PROBLEMS.

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5 · 6 . . . 12 · Next

AuthorMessage
Profile Heidi1
Avatar

Send message
Joined: 11 Aug 07
Posts: 49
Credit: 1,649,004
RAC: 0
Message 57505 - Posted: 2 Dec 2008, 20:05:25 UTC - in response to Message 57462.  

You can fix it yourself. Their instructions worked for me.
The problem is because they have moved to another server to ease the load.
Exit boinc and then
Open notepad and set it for all files
and then open the boinc file - in my case found in documents and settings/all users/application data/boinc.

There are three files to edit
client_state.xml,
client_state_prev.xml,
master_boinc.bakerlab.org_rosetta.xml

Open them in turn and enter \"schedule\" in the edit/find tab of notebook.
This will take you to the correct line.

<scheduler_url>http://bakerlab.org/rosetta_cgi/cgi</scheduler_url>
enter srv4. before the bakerlab.....
it will look like

<scheduler_url>http://srv4.bakerlab.org/rosetta_cgi/cgi</scheduler_url>


I followed the instructions, with both versions (the one quoted above and the version with srv4.boinc.bakerlab...), and neither worked. I now have an error message saying that there is no start tag in the server reply and that it can\'t parse the file. I don\'t know what that means, and what I can do to fix it, other than going to my backup of the files, copying them back into my computer, and hitting the Update button 11 times. Any thoughts?

ID: 57505 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Heidi1
Avatar

Send message
Joined: 11 Aug 07
Posts: 49
Credit: 1,649,004
RAC: 0
Message 57533 - Posted: 3 Dec 2008, 5:38:47 UTC
Last modified: 3 Dec 2008, 5:39:40 UTC

Never mind the above post. I twiddled with the xml files some more, ending up with reverting back to the original line in each. That following update got me hooked up with the servers, and it updated the xml files automatically.

For those who want the line, here\'s what it updated to:
http://srv4.bakerlab.org/rosetta_cgi/cgi
Notice it doesn\'t have the boinc.bakerlab... Keep in mind, in case it makes any difference, I\'m running XP with version 5.10.20.

Now all is well, with no creatures stirring (except my computer mouse!).
ID: 57533 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Willymiti

Send message
Joined: 15 Jan 08
Posts: 1
Credit: 3,030
RAC: 0
Message 57538 - Posted: 3 Dec 2008, 9:17:53 UTC

I just updated the rosetta project twice an the info tab said

03.12.2008 10:14:25|rosetta@home|Sending scheduler request: Requested by user. Requesting 0 seconds of work, reporting 5 completed tasks
03.12.2008 10:14:30|rosetta@home|Scheduler request succeeded: got 0 new tasks
03.12.2008 10:14:30|rosetta@home|Message from server: Server error: can\'t attach shared memory
03.12.2008 10:14:50|rosetta@home|Fetching scheduler list
03.12.2008 10:14:55|rosetta@home|Master file download succeeded
03.12.2008 10:15:00|rosetta@home|Sending scheduler request: Requested by user. Requesting 0 seconds of work, reporting 5 completed tasks
03.12.2008 10:15:05|rosetta@home|Scheduler request succeeded: got 0 new tasks
03.12.2008 10:15:05|rosetta@home|New computer location: home

Now it works again...
ID: 57538 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
peschue1

Send message
Joined: 24 Mar 08
Posts: 1
Credit: 46,678
RAC: 0
Message 57617 - Posted: 5 Dec 2008, 8:38:47 UTC

I had an empty master file for the rosetta project. So I updated client_state.xml and client_state_prev.xml and removed the empty master file. Starting BOINC after that downloaded the new master file and fixed the error message for me.

(The message did NOT disappear automatically after 10 tries)
ID: 57617 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Reaper

Send message
Joined: 12 Feb 06
Posts: 6
Credit: 364,880
RAC: 0
Message 57638 - Posted: 5 Dec 2008, 23:21:23 UTC

FWIW: I noticed that the
master_boinc.bakerlab.org_rosetta.xml is a different formatted file than the other two when edited with notepad, but my edits seemed to work.

I updated to 6.2.19 (before I read message boards and found this)
I tried Update several times, and even rebooted during an antivirus update to no avail.
I edited the three files in notepad and then started BOINC before the dreaded Server error: can\'t attach shared memory
was resolved.
Running Win 2K on Athlon XP 2000+, 1GB RAM
ID: 57638 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Keith T.
Avatar

Send message
Joined: 1 Mar 07
Posts: 37
Credit: 12,959
RAC: 0
Message 57705 - Posted: 8 Dec 2008, 18:14:16 UTC

I have also been unable to report completed tasks for the last week. I now have 2 tasks \"Ready to report\" which are getting close to deadline. I have tried manual updates with these results:

08/12/2008 18:05:11|rosetta@home|[sched_op_debug] Fetching master file
08/12/2008 18:05:11|rosetta@home|Fetching scheduler list
08/12/2008 18:05:16|rosetta@home|[sched_op_debug] Got master file; parsing
08/12/2008 18:05:16|rosetta@home|[sched_op_debug] Found 0 scheduler URLs in master file
08/12/2008 18:05:16|rosetta@home|[sched_op_debug] Deferring communication for 1 days 0 hr 0 min 0 sec
08/12/2008 18:05:16|rosetta@home|[sched_op_debug] Reason: 34 consecutive failures fetching scheduler list
08/12/2008 18:05:32|rosetta@home|[sched_op_debug] Fetching master file
08/12/2008 18:05:32|rosetta@home|Fetching scheduler list
08/12/2008 18:05:42|rosetta@home|[sched_op_debug] Got master file; parsing
08/12/2008 18:05:42|rosetta@home|[sched_op_debug] Found 0 scheduler URLs in master file
08/12/2008 18:05:42|rosetta@home|[sched_op_debug] Deferring communication for 1 days 0 hr 0 min 0 sec
08/12/2008 18:05:42|rosetta@home|[sched_op_debug] Reason: 35 consecutive failures fetching scheduler list
08/12/2008 18:05:57|rosetta@home|[sched_op_debug] Fetching master file
08/12/2008 18:05:57|rosetta@home|Fetching scheduler list
08/12/2008 18:06:02|rosetta@home|[sched_op_debug] Got master file; parsing
08/12/2008 18:06:02|rosetta@home|[sched_op_debug] Found 0 scheduler URLs in master file
08/12/2008 18:06:02|rosetta@home|[sched_op_debug] Deferring communication for 1 days 0 hr 0 min 0 sec
08/12/2008 18:06:02|rosetta@home|[sched_op_debug] Reason: 36 consecutive failures fetching scheduler list

The significant error seems to be Found 0 scheduler URLs in master file

Note my date format is European not USA.

Keith.
ID: 57705 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Path7

Send message
Joined: 25 Aug 07
Posts: 128
Credit: 61,751
RAC: 0
Message 57713 - Posted: 8 Dec 2008, 21:15:30 UTC - in response to Message 57705.  

Hello Keith T.

You might try the next link which brings you to a post from Evan at the Server Problem? - thread:
You can fix it yourself.

Good luck,
Path7.

ID: 57713 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Keith T.
Avatar

Send message
Joined: 1 Mar 07
Posts: 37
Credit: 12,959
RAC: 0
Message 57717 - Posted: 8 Dec 2008, 21:45:02 UTC - in response to Message 57713.  

Hello Keith T.

You might try the next link which brings you to a post from Evan at the Server Problem? - thread:
You can fix it yourself.

Good luck,
Path7.



I tried just editing client_state to put the new url in still got the error. I will try editing the client_state_prev as well later, but I think I have spotted the error in the master file.

There is a [SPACE] in the file where I think there should not be.

<scheduler>http://srv4.bakerlab.org/rosetta_cgi/cgi </scheduler>
<scheduler>http://srv4.bakerlab.org/rosetta_cgi/cgi</scheduler>
ID: 57717 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Keith T.
Avatar

Send message
Joined: 1 Mar 07
Posts: 37
Credit: 12,959
RAC: 0
Message 57720 - Posted: 8 Dec 2008, 23:17:37 UTC

Looks like my guess was right. The master_boinc.bakerlab.org_rosetta.xml has been updated without the [SPACE] and I have now been able to connect and report results.

Thanks to the admin that corrected this.

Keith.
ID: 57720 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Rick Lowrey

Send message
Joined: 7 Sep 08
Posts: 1
Credit: 1,015,413
RAC: 0
Message 57756 - Posted: 9 Dec 2008, 22:39:19 UTC - in response to Message 57720.  

I updated client_state.xml and client_state_prev.xml and master file. I also found and removed that space. That still didn\'t work. So, I renamed the master file to .old and then Boinc said \"Master file download succeeded\". Now it downloaded some new work units and seems happy again. I guess we\'ll see in a few hours when it tries to upload.
ID: 57756 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
michaelmastro
Avatar

Send message
Joined: 11 Oct 05
Posts: 51
Credit: 1,530,918
RAC: 0
Message 57852 - Posted: 13 Dec 2008, 16:25:48 UTC - in response to Message 57462.  

I updated the files on three machines - 2 macs and a vista. Problem solved on two out of three. On my Mac Dual 533 OSX 10.4.11, when I opened (in TextEdit like the other two) \"master_boinc.bakerlab.org_rosetta.xml\" it opened as a web page and when I searched for \"schedule\" there are no results. Please advise.

Thank you, in advance...

ID: 57852 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Mod.Sense
Volunteer moderator
Project administrator

Send message
Joined: 22 Aug 06
Posts: 3550
Credit: 0
RAC: 0
Message 57856 - Posted: 13 Dec 2008, 18:30:06 UTC - in response to Message 57852.  

On my Mac Dual 533 OSX 10.4.11, when I opened (in TextEdit like the other two) \"master_boinc.bakerlab.org_rosetta.xml\" it opened as a web page...


two thoughts... one, just let it do it\'s retries and it will fix itself.
Two, open your text editor first, then use it to open the .xml file.
Rosetta Moderator: Mod.Sense
ID: 57856 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
michaelmastro
Avatar

Send message
Joined: 11 Oct 05
Posts: 51
Credit: 1,530,918
RAC: 0
Message 57857 - Posted: 13 Dec 2008, 18:37:34 UTC - in response to Message 57856.  

On my Mac Dual 533 OSX 10.4.11, when I opened (in TextEdit like the other two) \"master_boinc.bakerlab.org_rosetta.xml\" it opened as a web page...


two thoughts... one, just let it do it\'s retries and it will fix itself.
Two, open your text editor first, then use it to open the .xml file.



I reset Rosetta - no change.
I opened text editor, then .xml - same result - web page...

ID: 57857 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Path7

Send message
Joined: 25 Aug 07
Posts: 128
Credit: 61,751
RAC: 0
Message 57871 - Posted: 14 Dec 2008, 20:43:28 UTC

Hello all,

Since 10:00 UTC both the home page and the Server Status Page are showing a (very) small amount of Wu\'s Queued & Ready to send.
And the message:
rah_make_work1 srv3 Not running

Just saw my notebook had to do 5 attempts to download a single WU.

I hope the techs are aware of this.

Have a nice day,
Path7.
ID: 57871 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
ComfortablyNumb

Send message
Joined: 6 Jul 07
Posts: 8
Credit: 658,196
RAC: 0
Message 57873 - Posted: 14 Dec 2008, 21:17:54 UTC

I can\'t download any new wu\'s. I\'ve tried resetting the project twice...hasn\'t worked.
ID: 57873 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Greg_BE
Avatar

Send message
Joined: 30 May 06
Posts: 4871
Credit: 3,740,253
RAC: 2,321
Message 57875 - Posted: 14 Dec 2008, 23:00:31 UTC - in response to Message 57873.  

can you post some of the message text from boinc manager relating to this issue?

I can\'t download any new wu\'s. I\'ve tried resetting the project twice...hasn\'t worked.

ID: 57875 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Paul

Send message
Joined: 29 Oct 05
Posts: 190
Credit: 59,586,292
RAC: 4,181
Message 57876 - Posted: 14 Dec 2008, 23:13:44 UTC - in response to Message 57875.  

Same thing for me. I am reporting tasks complete and requesting new work and receiving 0 new tasks.

looks like a problem.
Thx!

Paul

ID: 57876 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Lazlo
Avatar

Send message
Joined: 24 Oct 08
Posts: 3
Credit: 686,339
RAC: 0
Message 57879 - Posted: 15 Dec 2008, 1:19:24 UTC

receiving 0 tasks...why? unchanged prefs get me up to 4 days worth of tasks normally....

BOINC Manager Messages tab indicates that roseeta@home is sending completed tasks and requesting new ones, but nothing is being sent.

\"Sending scheduler request: To fetch work. Requesting 117686 secongs of work, reporting 0 completed tasks\"

and

\"Scheduler request succeeded: got 0 new tasks\"

repeated with variations of #seconds of work for the last couple of hours.


any idea why?
A gentleman is supposed to prefer being a dead lion to a live jackal. Me, I've always preferred to being a live lion, so that leaves me outside the rules. L.Long
ID: 57879 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
AMD_is_logical

Send message
Joined: 20 Dec 05
Posts: 299
Credit: 31,460,681
RAC: 0
Message 57880 - Posted: 15 Dec 2008, 1:31:00 UTC - in response to Message 57879.  

\"Scheduler request succeeded: got 0 new tasks\"

repeated with variations of #seconds of work for the last couple of hours.


any idea why?

Yes. One of the two work generator programs is down today, and the remaining one isn\'t able to generate enough WUs.
ID: 57880 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
AMD_is_logical

Send message
Joined: 20 Dec 05
Posts: 299
Credit: 31,460,681
RAC: 0
Message 57881 - Posted: 15 Dec 2008, 5:03:17 UTC

Looks like both work generators are working, and there are now plenty of WUs ready to send.

Thanks (to whoever fixed that).
ID: 57881 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Previous · 1 · 2 · 3 · 4 · 5 · 6 . . . 12 · Next

Message boards : Number crunching : SERVER PROBLEMS.



©2020 University of Washington
http://www.bakerlab.org