process exited with code 193 (0xc1)

Questions and Answers : Unix/Linux : process exited with code 193 (0xc1)

To post messages, you must log in.

AuthorMessage
Astropoint

Send message
Joined: 13 Oct 05
Posts: 7
Credit: 2,921,431
RAC: 71
Message 45310 - Posted: 23 Aug 2007, 12:59:01 UTC

I recently put Rosetta onto a ubuntu machine using the boinc version from synaptic. However, 4 of the 5 WUs that it has actually run so far have ended with a client error giving "process exited with code 193 (0xc1)". The machine in question is here: https://boinc.bakerlab.org/rosetta/results.php?hostid=584624

I searched the forums for other people getting this error, but the only posts were from about a month ago and no actual solution I could see. Could the version of boinc I have be wrong, or does anybody have any ideas.

I have paused rosetta on there for now and let it run other projects, seti and Einstein, both of which are running fine and returning good WUs.
ID: 45310 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Mod.Sense
Volunteer moderator

Send message
Joined: 22 Aug 06
Posts: 4016
Credit: 0
RAC: 0
Message 45319 - Posted: 23 Aug 2007, 17:11:50 UTC

Not sure what causes this issue, but it seems most common on Linux boxes.

Looking at your host, I see you are running 5.4.9 BOINC? So I'd suggest you start there, and get up to the current stable release 5.8 and see if that helps.
Rosetta Moderator: Mod.Sense
ID: 45319 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Astropoint

Send message
Joined: 13 Oct 05
Posts: 7
Credit: 2,921,431
RAC: 71
Message 45327 - Posted: 23 Aug 2007, 21:50:33 UTC

I updated my client version to 5.8.16, and the same thing happened with the first 2 WUs it processed:
https://boinc.bakerlab.org/rosetta/result.php?resultid=101443749 and https://boinc.bakerlab.org/rosetta/result.php?resultid=101442357

The problem seems to occur after 1 hour into computation when boinc tries to pause the WU and start a different project, so I'll try running just rosetta for a while and see if that works, unless anybody has a better idea?
ID: 45327 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Astropoint

Send message
Joined: 13 Oct 05
Posts: 7
Credit: 2,921,431
RAC: 71
Message 45347 - Posted: 24 Aug 2007, 17:00:36 UTC

Just running rosetta seemed to make the WUs complete successfully, as did setting rosetta to leave the applications in the memory when suspended. Neither of these is exactly ideal. Has anybody got any other suggestions?
ID: 45347 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
DJStarfox

Send message
Joined: 19 Jul 07
Posts: 140
Credit: 1,077,470
RAC: 136
Message 46381 - Posted: 16 Sep 2007, 18:48:43 UTC - in response to Message 45347.  

Just running rosetta seemed to make the WUs complete successfully, as did setting rosetta to leave the applications in the memory when suspended. Neither of these is exactly ideal. Has anybody got any other suggestions?


Yeah, I had this exact problem if leave applications in memory = no. They haven't fixed it yet. It pisses me off that the R@H application doesn't uninitialize properly as all other projects do. I guess it doesn't use checkpoints properly or something.

What you could help is the switching applications behavior of BOINC. Set your Rosetta Target CPU Run Time to 2 hours and set your global preference Switch Between Applications to 2 hours (the same value or higher). That way it won't switch while Rosetta is working.
ID: 46381 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Jakob Creutzfeld
Avatar

Send message
Joined: 7 Sep 06
Posts: 8
Credit: 26,194
RAC: 0
Message 47266 - Posted: 1 Oct 2007, 10:57:32 UTC
Last modified: 1 Oct 2007, 10:57:44 UTC

Add me and my Linux-Box to the list of affected machines ;-)

Regards
Andy
ID: 47266 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Raimund Barbeln

Send message
Joined: 19 Sep 05
Posts: 2
Credit: 1,186,250
RAC: 430
Message 47416 - Posted: 5 Oct 2007, 9:47:56 UTC

I have the same problem on my linux machine, but it is not consistent.
Some WUs finish without problems, but others, after running fine for a while, just sit around doing nothinig, until they error out eventually with error 139.
This is a dual core AMD machine and the error makes one core sit completely idle.
ID: 47416 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
vakobo

Send message
Joined: 3 Aug 08
Posts: 18
Credit: 11,480,178
RAC: 3,899
Message 88774 - Posted: 29 Apr 2018, 13:48:09 UTC
Last modified: 29 Apr 2018, 13:51:11 UTC

After some system update (Debian x64) all new WU's ends with exit code 193 https://boinc.bakerlab.org/result.php?resultid=993426232.
How it happens: WU download ends, computation starts and after few seconds finish with computation error. Event log says that output file ___ for task ___ absent.
All previously started WU's was finished fine.
ID: 88774 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
vakobo

Send message
Joined: 3 Aug 08
Posts: 18
Credit: 11,480,178
RAC: 3,899
Message 88792 - Posted: 2 May 2018, 9:40:26 UTC - in response to Message 88774.  

Additional information:
This behavior was with Rosetta 4.07 WU's.
Today WU's for Rosetta Mini starts fine but some time later BOINC lose connection and now there is no project in project list and no possibility to add it.
ID: 88792 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Narakis

Send message
Joined: 17 Sep 05
Posts: 2
Credit: 1,764,009
RAC: 864
Message 88797 - Posted: 2 May 2018, 15:24:37 UTC - in response to Message 88792.  

I can confirm this problem.
Running Debian-Testing.
Seems like others have got the same problem.
https://boinc.bakerlab.org/rosetta/forum_thread.php?id=12242&postid=88775#88775
ID: 88797 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
dhh

Send message
Joined: 4 May 14
Posts: 2
Credit: 2,001,836
RAC: 0
Message 88852 - Posted: 11 May 2018, 9:16:39 UTC

Just a confirmation from my side. The problem seem to be with Rosetta 4.0x WUs and on Debian 10 (aka "testing", "buster"). I have had the issue on various machines, re-install doesn't help either. BOINC and other BOINC projects are working fine.
ID: 88852 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
dhh

Send message
Joined: 4 May 14
Posts: 2
Credit: 2,001,836
RAC: 0
Message 88868 - Posted: 12 May 2018, 6:23:24 UTC

Update: The latest Ubuntu 18.04 is affected too (definitely kubuntu 18.04).
ID: 88868 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
vakobo

Send message
Joined: 3 Aug 08
Posts: 18
Credit: 11,480,178
RAC: 3,899
Message 89078 - Posted: 7 Jun 2018, 18:17:47 UTC
Last modified: 7 Jun 2018, 18:25:48 UTC

Rosetta Mini works fine. Rosetta 4.07 still generates computation errors.
Debian GNU/Linux testing (buster) [4.16.0-2-amd64|libc 2.27 (Debian GLIBC 2.27-3)]
BOINC 7.10.2
ID: 89078 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
blazingcherub

Send message
Joined: 5 May 18
Posts: 1
Credit: 74,563
RAC: 1
Message 89250 - Posted: 9 Jul 2018, 18:33:17 UTC

Same here. Sometimes (but very seldom) it finishes Rosetta 4.07 tasks complete without error but 90% of them have status "Error while computing". But there is no problem with Rosetta Mini. Is there any way to switch to Rosetta mini only tasks?

My system is Ubuntu Server 16.04
ID: 89250 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote

Questions and Answers : Unix/Linux : process exited with code 193 (0xc1)



©2020 University of Washington
https://www.bakerlab.org