Posts by LC

1) Message boards : Number crunching : Problems and Technical Issues with Rosetta@home (Message 80797)
Posted 27 Oct 2016 by LC
Rosetta@home does not do such thinking. It is the BOINC Manager...

Gotcha, mea culpa.

You started out saying your machine has limited access to internet...If you do have access full-time, then you new settings sound much more appropriate.

My laptop has some sort of sporadic wifi disconnect issue and almost every night I lose connectivity for varying amounts of time, usually several hours. Sorry, I didn't intend to imply it was worse than this but from my POV the connection drops are very annoying.

As for the earlier discussion about "holding up the science"...

Thanks for that info, I wasn't aware of any of that. Learned a bunch of new things now.

I actually agree with you here. I didn't know that first setting did what Juha says it does (but Mod-Sense reminds me that it did used to be called 'connect ever x days' so maybe I just forgot). Upshot is, I agree you should set this at zero and use the next field to determine how many days worth of tasks you'd like.

I already changed it to 2+5 but I'll probably just drop it to 0+5ish because as you've guessed, yes, I do already have the cache behaviour I was looking for.

After everything you guys have taught me over the past couple days, I'd agree with what everyone seems to be leaning towards - 1 hour runtimes should probably be dropped, maybe even 2 hour ones but I think I would prefer to keep 4. Some 'part-timers' only contribute very small chunks of time and may miss deadlines if you raise the minimum too high. To be honest, I would have set my runtimes higher from day one had I known what I know now.

Thanks for all the help everyone. I'll report back when I have time to test more changes.
2) Message boards : Number crunching : Problems and Technical Issues with Rosetta@home (Message 80790)
Posted 26 Oct 2016 by LC
Your host didn't receive less than 10 days of work because BOINC assumed that the next time your host would be online would be 10 days from the moment your host requested work.
That setting is a tricky one. I think you are not the first one to get bitten by it.

But why would Rosetta think my personally-preferred Cache/WU buffer has anything at all to do with my online status? BOINC runs well over 80% of the time for my computer and out of that amount of time BOINC probably has internet connectivity at least 80% of the time if not 90%+.
WU cache and internet connectivity percentage /may/ be related in some instances but they are in fact separate things.
For someone using *web* preferences, there is a specific and separate setting under "Computing Preferences" which specifically asks how often your computer is connected to the internet and it states it will try to give you that much work to keep you going. In my case of using *local* preferences, there is no such setting. Local computing /preferences/ allow you to request a minimum buffer ("Store at least X days of work.") and a maximum ("Store up to an additional X days of work."). These are merely preferences...if Rosetta feels it needs to give you less because of shorter deadlines then it should give you less...not cut you off entirely.

I think you're absolutely right - this setting is tricky. BUT now I think we've found a way to deal with it. If using *local* preferences, the trick seems to be to set the "Store /at least/" setting to a very low number and set the "Store /up to an additional/" setting to whatever higher number you want.

I had set the "at least" setting high because I was hoping to keep a 'high minimum' buffer...which is all that setting /should/ be about. But you guys have helped prove there's obviously a second variable at work. I still want to set my minimum amount high but now that I think about it maybe there's no need to. seems we've figured it out and we've figured out how to work around it. Very interesting stuff. I hope this thread comes in handy to anyone else who runs into the same issue. I'll update here again when I have a chance to play around with this more. Thanks again to everyone for all your time, help & suggestions.

Side note - I understand the server-load effects of all these settings manipulations but it would be great to hear from someone inside Rosetta as to what they prefer. From my POV, if they offer 1-hour WUs, I would think they're happy enough to have me work on a bunch. If however they really prefer longer WUs, I would be very willing to increase my setting to accommodate. To be honest, I'll probably change it anyway just for the sake of being different.

By the way, I now have about 80 WUs due the 31st October and about 200 due the 2nd November. I haven't changed anything since my last post.

Thanks again everyone, I'll update again soon.

3) Message boards : Number crunching : Problems and Technical Issues with Rosetta@home (Message 80787)
Posted 26 Oct 2016 by LC
Well that was fast...

I changed from "Store at least 10 days" to storing at least 2 days.
I changed "Store up to an additional 10 days" to storing up to 5 days.

I now have 38 tasks due on 31st October and 66 due on 2nd November. So my buffer is back! Yay. Now it's time for me to understand what the problem was. Because it still makes no sense.

So I /was/ asking for 10 days worth of work before, with /potentially/ another 10 days on top of that for a total of 20 days worth of work. According to Juha, Rosetta presently has WUs due in either 2, 5 or 7 day deadlines. So *obviously* under those circumstances, I should not be given 10 days worth of work, much less 20 days worth, because if I were, then anything after 7 days wouldn't finish in time.

BUT what the heck? WHY wasn't I being given at least 7 days of work instead? Or 5 days instead? Or 2 days? WHY do I all of a sudden have to know what Rosetta's deadlines are for their WUs? I never knew before and everything worked just fine. This only makes partial sense *if* Rosetta had 10-day deadlines over the past 7 years...until just a few weeks ago. And even if that were true, it still makes no sense to prevent me from having ANY additional days at all when I'm requesting the max. If you can't give me 10 days that's ok, no big deal, but give me 7 days, or 5, or 2! If I'm requesting 10 days and it's blatantly obvious I can crunch dozens of WUs per day, why was I being *entirely* cut off from having a single extra WU?

I'm not upset, I'm just confused because it doesn't make sense to have not allowed me to have ANY extra WUs and it makes even less sense that this problem came up suddenly out of nowhere after I had 7 years with the same settings.

I think I understand what's happening right now but it doesn't seem to make sense that it's happening suddenly and it certainly doesn't make sense that I was being entirely cut off from having any additional WUs. Logically, given my max settings, I should have just been given the slightly lesser amount of buffer WUs which I could in fact handle. So what happens now if Rosetta drops 7-day deadlines? I'll run out of *all* buffer WUs yet again and have the same exact problem instead of being given the 'X' amount of 2-day deadline work which I can handle? That doesn't make sense to have that happen because you're forcing people to know Rosetta's deadlines as they choose to change them. I don't work in the lab...I just want the max they'll allow me in an amount which my computer can handle. As I said in an earlier post, I've never had major problems not meeting deadlines because BOINC "learns" the amount of WUs your computer can handle.

Don't misread me, I'm not upset over any of this, I just think something needs to be tweaked with the way buffer preferences are handled by Rosetta. And I still don't understand how/why this problem suddenly became an issue out of nowhere a few weeks ago.

Time for me to go do some more re-reading & testing. I'll post again after I learned more. Thanks again!
4) Message boards : Number crunching : Problems and Technical Issues with Rosetta@home (Message 80785)
Posted 26 Oct 2016 by LC
@Juha & @Sid

I need to take a little time to re-read and more fully understand what you're telling me. At the moment I think I understand the basics of what you're both saying but there's one glaring fact that's causing me some confusion. - All of my settings have been basically the same since I first started crunching.
Starting 7 years ago, every time I brought in a new computer (12 different computers over 7 years), I have set up every single one with almost identical settings and I'm certain I requested the "10 + 10" every single time...and I've never had any problems until a few weeks ago. I've never had major problems making deadlines. I've always had a good buffer of WUs. I've been happily crunching away with Windows XP, Windows Vista, Windows 7, Windows 10 & Linux Mint. I had a 3-year hiatus in the middle but I've still put up almost 1.2 million points for I don't understand how such a sudden and drastic change in my additional WU stash could be caused by my settings which have basically never changed. When something works for 1.2 million points over 7 years on a dozen different machines, with 5 different OSs, that's a pretty good case for reliability.

*I very much appreciate everyone's help*. You've given me a good bit to re-read and better understand so let me go through it & I'll be back here once I've tried some things. Thank you very much to everyone helping out.

I'm already testing some of the suggestions you've all offered so hopefully I can report back with good news soon. Thanks again!
5) Message boards : Number crunching : Problems and Technical Issues with Rosetta@home (Message 80779)
Posted 25 Oct 2016 by LC
Did you by chance hit the 'Show active tasks' button...

No offense taken at all. Yes, I have checked the Active Task button and that's not it. My wifi randomly cuts out on my quad core Asus and the only way to fix it is to manually restart the whole laptop. (The wifi problem has nothing to do with anything else here.) When the signal dies overnight, within an hour or two I'm out of work units because of this lack of buffer-WUs issue. If I had mistakenly 'hid' the tasks I'd still have a steady, uninterrupted stream of production, if I wasn't having this actual problem.

a 10 day buffer...seems really really excessive...why be the one guy slowing down pace of iteration/experimentation by making researchers wait a whole 10 days?... just a thought.

I never really thought of it that way but I don't think that's exactly how it it? *I could definitely be wrong* but it's my understanding the same WUs are sent to a bunch of people. It would be risky to rely on the results of a single computer so several (dozens??) computers are used to work on the same WU so results can be compared. Also, *I could be mistaken*, but I don't believe anyone's buffer is 'holding up' research. When everything is working correctly on both ends & BOINC on my end 'learns' how many WUs I average, I'm only given the WUs I can handle by the deadline. Nearly all of my WUs are completed ahead of the deadline so I would assume this doesn't 'hold up' research. Maybe I'm wrong but I'm assuming everyone's happy as long as I'm meeting deadlines. Thanks for your POV though, I never thought of it that way. Any mods have an opinion on this?

some of the simulations being run on R@H can complete in just a few days

DAYS? For one work unit? I've never read anywhere if the researchers prefer a long run-time-per-WU over a short run-time-per-WU so I've always (7 years now) had my preferences set to shorter WUs.
Thanks for the input Timo, I appreciate it.

Please, stop all "2xa0_Xcdp_" wus....

I'm not sure if your message was for me but I haven't seen any WUs with that info yet. It's not possible for me to keep constantly checking due to my present problem though.
6) Message boards : Number crunching : Problems and Technical Issues with Rosetta@home (Message 80776)
Posted 25 Oct 2016 by LC
Have you checked which venue your machines are in?

Good idea, hadn't thought of that. Just checked it now...I have no venue settings. Home, School and Work have all been left blank, leaving only the main Preference(s). I just now tweaked the main settings slightly just for the sake of doing so but neither of my computers are set to use web preferences. I have both set to use local preferences since there is a vast gap between them in CPU & RAM capabilities. I slightly tweaked the local settings on both computers a number of days ago in the hope that would work. No dice.

I wonder if your preferences got messed up during the database issues they had.

That's exactly what I've been thinking because the timing is just too much of a coincidence...but I see no evidence of that on my end and I've re-tweaked everything already. I don't remember messing with ANY of my settings for quite some time until this issue. I brought the old Dell out of retirement just to see if it was a problem with my quad core computer.

It is almost acting like a project that the BOINC Manager thinks has a resource share of zero (a "backup" project).

I never knew that trick, cool idea, thanks.

Suggest you look at message log to see which project is hosting your preferences. Then revise the settings for days of cache and resource share on that project to a new value so the values get reset in the server. And then have you overridden the project settings on your two host machines? Maybe tweak the values there too, just to force it to replace them.

I've never used/read the Message Log before, great idea, thank you! I've just now checked it. I've already re-tweaked everything. I only run Rosetta and all my preferences are derived from there...but you are right...

Something very odd going on.

24-Oct-16 23:03:11 | rosetta@home | Sending scheduler request: To fetch work.
24-Oct-16 23:03:11 | rosetta@home | Requesting new tasks for CPU and Intel GPU
24-Oct-16 23:03:13 | rosetta@home | Scheduler request completed: got 0 new tasks
24-Oct-16 23:03:13 | rosetta@home | No work sent
24-Oct-16 23:03:13 | rosetta@home | (won't finish in time) BOINC runs 86.5% of time, computation enabled 99.5% of that
24-Oct-16 23:09:22 | rosetta@home | Sending scheduler request: To fetch work.
24-Oct-16 23:09:22 | rosetta@home | Requesting new tasks for CPU and Intel GPU
24-Oct-16 23:09:24 | rosetta@home | Scheduler request completed: got 0 new tasks
24-Oct-16 23:09:24 | rosetta@home | No work sent
24-Oct-16 23:09:24 | rosetta@home | (won't finish in time) BOINC runs 86.5% of time, computation enabled 99.5% of that

Why does BOINC not think I can finish in time? (Time and date are accurate on my computers.) I routinely complete dozens of work units per day, this '1 for 1' swap has been going on for over a week. 86.5% up-time on a quad core i3 with 6GBs of RAM has been giving me *well* over 300 work units in my buffer until this recent issue.

(Yes, my Tasks view is View ALL Tasks.)

Is it time to tr the "Reset Project" button? Do I need to reinstall BOINC?

Sorry for the long replies but I want to provide as much relevant detail as possible. I appreciate your time & help, thank you.

7) Message boards : Number crunching : Problems and Technical Issues with Rosetta@home (Message 80772)
Posted 24 Oct 2016 by LC

One way this might happen is if you have other BOINC Projects...

It may just be coincidence that you get the number of tasks that you do happen to match your number of CPUs.

With your limited memory...

You can adjust the resource shares between projects...

Thanks for the quick reply!
To your points above...

I don't have any other projects. I used to work on SETI and Rosetta together but I have long since removed SETI from my list of projects (therefore Rosetta has 100% resource share). That's why I don't believe it's any coincidence I'm getting a "1 for 1" swap with Rosetta workunits. Within minutes of a core completing a work unit it gets reported and replaced with a single new one to keep the core busy again. 1 for 1. It's been like this for about 2 weeks or so. My 10 day buffer started slowly dropping 3 or 4 weeks ago.

Starting soon after the server crash, it looks like Rosetta purposely allowed my 10 day buffer to go to zero and it's only giving me the most absolute minimum work units to keep each of my 4 cores busy. ---I should mention, my posts here aren't a complaint really, I was just surprised nobody else had mentioned this behavior. If Rosetta is running low on work units to send people, I would think this is happening to everyone, so by no means am I upset, just curious.--- I've been assuming this was happening to everyone because of the server issues. I was hoping I'd get my 10 days of work units back when the servers get fixed.

I have a second computer (an old Dell single core) experiencing the same '1 for 1' issue. Each computer has different Local Computing Preferences (which is what I have them both set to use) and yes, I even checked my web preferences and that's set to 10 extra days also.

My old single-core Dell finishes several work units per day earning maybe a couple hundred points per day. My quad core averages dozens of work units per day giving me an average of over 1100 points per day.

My quad core is a 64 bit i3 with 6GB RAM on Windows 10...plenty of RAM.

I know I /could/ add SETI or another project to keep my CPUs warm but Rosetta is the only one I really wanted. We'll see.

I'm assuming there's nothing I can do to get buffer units for Rosetta until they replace the servers. I'm assuming this is happening to someone else besides me & my 2 computers.

Thoughts, comments & ideas from anyone are welcome. Thanks for your help.

(ps - I have an Nvidia Shield K1 Android tablet. Any idea if/when I might be able to use it for Rosetta?)

8) Message boards : Number crunching : Problems and Technical Issues with Rosetta@home (Message 80769)
Posted 24 Oct 2016 by LC
I'm brand new on the forum but I've been crunching for several years.

I've read this entire thread, there are some posts beyond my technical comprehension but as far as I can tell nobody has brought up the problem I'm having...

I know we're all limping along as we await the new servers to be built but I'm only being given active work units, it's not allowing me to keep any 'stored'/'buffer' units. In other words my quad core cpu computer is only being given a max of 4 work units to crunch at a time, as it finishes one unit it reports it and one work unit will be sent back to replace it 1 for 1. My preferences have been the same for years - 10 days of work plus an additional 10.

My sizeable buffer began to diminish during the 1st or 2nd week of October. The reason I'm posting here is because my computers don't always have access to the internet and so I'm missing out on quite a bit of work. I've waited a few weeks to see if it would fix itself but no luck.

The only thing I *haven't* done yet is re-install BOINC but I don't think that's the issue. I'm on 7.6.22 (x64)

Thank you.


©2023 University of Washington