Posts by George

1) Questions and Answers : Windows : "No schedulers responded" (Message 14092)
Posted 18 Apr 2006 by Profile George
Post:
I have exactly the same problem with the same exact messages. I am connecting through a proxy but the evidently the connection is successful since BOINC was able to 'download the master file'. I am using version 5.2.13 which I first installed about two weeks ago. I have removed the application, rebooted, removed the installation directory, and reinstalled it several times to try to fix this. This feels like a bug.
2) Message boards : Number crunching : Warning: Don't shut down BOINC Manager..!! (Message 5308)
Posted 6 Dec 2005 by Profile George
Post:
Things seem to be running well enough now that I don't think there's any use refining. However, I still suspect Konfabulator might be conflicting with Rosetta in some way because I've seen it (Konfabulator ) crash a few times recently for no apparent reason and that's never happened before. It's a desktop widget thingie that might be getting into Rosetta's face for video resources.

Bill, thanks for all your help.

You're over my head on the leak thing. Yesterday I noticed something funny, though. I had a web app running in Tomcat that creates JPEG files, and I commented out the ObjectOutputStream.close() statement to learn more about an I/O error I was getting. I found that even after shutting down Tomcat I could not delete the directory the files were created in. Windows Explorer hung for a while and finally refused to delete them when I attempted to, complaining that they were locked. I decided to reboot and while the system was shutting down I saw Windows Explorer (which had hung again after I asked it to delete them) suddenly delete the directory, then exit. Something was holding them open, but the JVM process in which they were created was gone.

For my purposes, writing clean I/O is sufficient. Anything that happens when I don't is in the PFM category (pure magic).
3) Message boards : Number crunching : Warning: Don't shut down BOINC Manager..!! (Message 5194)
Posted 5 Dec 2005 by Profile George
Post:
Back for a moment to 'client errors'. My old, slow host 76452 that was returning WUs with errors consistently now seems to have gotten over its problems. I did reboot it several times over the weekend and in the process found that it was booting up and automatically logging in (to WinXP) as admin. I think it was trying to run the same WU in two different processes as two different users. I think I've fixed that, and I see at least some successes coming from that machine now.

However, of the two systems that are up and online 24x7 (76452 and 78132), I seem to be getting spurious 'client errors' in the results. If this is something I can fix I'd like to, but I'm not finding any help on the bakerlab site to help me determine the root cause.

Also, I noticed that the faster machine somehow finished 28 WUs in less than 24 hours yesterday (this seems unlikely) and then returned a string of errors because BOINC would not assign it any more work, and yet it continued to solicit more work, and each of the dozens of attempts was recorded as as an error. No biggie, but it seems the client ought to be smart enough to back off when the server says to.

Now to OO languages and memory leaks. I lead a Denver Java User Group Object Orient Architecture Special Interest Group (say that fast five times!). We had a Sun master instructor speak on garbage collection in Java recently. I was a bit surprised that Java can have memory leaks until I realized what he was talking about was simply opening a file handle or connection or whatever and not closing it in a JVM that doesn't terminate for long periods. This is poor form even in a 'safe' language, and the programmer can certainly be blamed. However, when the JVM terminates, my understanding is that any open resources are then released. I'm not sure this is true with C. I think there are situations where even after the process terminates that owns the resource, the OS cannot reclaim it. I don't know C well - is this true?

The moral, I guess, is that memory leaks can and do occur even in 'safe' languages, but in programs that are not services (processes that run indefinitely), the 'safe' languages are indeed safe. Make sense?

G
4) Message boards : Number crunching : Warning: Don't shut down BOINC Manager..!! (Message 4981)
Posted 2 Dec 2005 by Profile George
Post:
Okay, we may get to file this in the "shut up and reboot" Windows drawer. Just for kicks and giggles I restarted - hadn't done it for a couple of weeks, I think - and now everything seems fine. Rosetta's running, CPU is at 100%, graphics come up fine, everything looks peachy. I can see the CPU time for Rosetta (in BOINC Manager Work tab) counting up, but it seems to be counting up from the stalled number I saw before, implying that Rosetta really was making no progress while the CPU load was 0%.

I'll continue to monitor it. If it's all fixed by the reboot, I should see my average WU/day rate rise for this computer. But it does seem as if Windows can get into a state that starves Rosetta but not Seti without any alarms going off.

To answer your question, yes, I had the line that showed Rosetta running selected when I clicked "Show Graphics".

Lowfield, what happens if you reboot (if you can)?
5) Message boards : Number crunching : Warning: Don't shut down BOINC Manager..!! (Message 4977)
Posted 2 Dec 2005 by Profile George
Post:
:( Sorry to hear about the service provider woes. I feel your pain - I have them too. I'm thinking about moving to Russia for the more enlightened customer service due to competition...

Right now with Rosetta running (as shown in BOINC Mgr) on 78132 Task Manager shows 0% CPU usage. In the Task Manager process list, sorted by CPU load, Rosetta is near the top while memory for the process is ~20MB, but System Idle process shows 90 - 100%. The next highest process for CPU time is task mgr and Konfabulator (have you tried it? It's great - konfabulator.com) at a few % each.

The CPU time in BOINC Mgr for Rosetta has not changed in the 10 or so minutes I've been watching. It certainly appears no work is being done and cycles are being wasted. One Seti process is preempted while another shows "Ready to report". If I click "Show Graphics", nothing happens, but I know this has worked for me before because I've seen the Rosetta graphics while a WU was running - very impressive.

I wonder if something is conflicting with Rosetta. It certainly seems to be stalled.
6) Message boards : Number crunching : Warning: Don't shut down BOINC Manager..!! (Message 4958)
Posted 2 Dec 2005 by Profile George
Post:
Wow. What a response. If only my cell phone provider and ISP could be a quarter as responsive! And I pay them big bucks.

Sitting here at 78132 The CPU is showing 0% usage in Task Manager while Rosetta shows as 'Running' and Seti shows 'Preempted' in BOINC Manager. Darn those pesky trans-dimensional aliens! I don't care about the reported CPU usage as long as the WU is getting done, but if there is some weirdness perhaps we should know about it and publish it so others don't get similarly confused. If so we should start another thread with a more germane title.

I do have "Do work while computer in use?" set to 'yes'.

Thanks so much, and I'll keep an eye on it and report back.
7) Message boards : Number crunching : Warning: Don't shut down BOINC Manager..!! (Message 4938)
Posted 2 Dec 2005 by Profile George
Post:
Thanks for the help. Both systems have the symptom. 78132 is the fast one and I'm guessing it is the one with few errors. 76452 is an older slow systgem but hosts some servers and so is on all the time. The errors may come from me suspending and resuming work in attempts to get the CPU usage up. I do see 'Running' when the CPU usage is near zero in Task Manager. As soon as I suspend Rosetta and Seti starts, usage jumps to 100%, then I resume Seti and it drops back down.

I did have 'leave app in memory' set to no in general prefs, just switched it to yes, we'll see if that's it. Thanks again for the pointer.
8) Message boards : Number crunching : Warning: Don't shut down BOINC Manager..!! (Message 4905)
Posted 2 Dec 2005 by Profile George
Post:
This is a bit off topic, but for some reason when Rosetta is running my CPU load is not 100% as I expect it to be because Seti@home uses all the CPU. Is this normal, or have I set something wrong in preference? I have both Seti and Rosetta attached. When Seti runs the CPU load is 100%; when Rosetta runs it's near 0%.

Thanks for any help.






©2024 University of Washington
https://www.bakerlab.org