BOINC 5+ upgrade

Message boards : Number crunching : BOINC 5+ upgrade

To post messages, you must log in.

AuthorMessage
Profile David E K
Volunteer moderator
Project administrator
Project developer
Project scientist

Send message
Joined: 1 Jul 05
Posts: 985
Credit: 2,630,463
RAC: 1,248
Message 999 - Posted: 6 Oct 2005, 0:19:45 UTC

The server and web site upgrade to BOINC 5+ is complete. Work is flowing again and the site seems okay and functional. There are some minor changes in the look and feel of the web site that were added to stay consistent with BOINC and to make future upgrades easier. Please post any significant issues that come up regarding the server and site upgrade in this thread.
ID: 999 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Shaktai
Avatar

Send message
Joined: 21 Sep 05
Posts: 56
Credit: 575,419
RAC: 0
Message 1001 - Posted: 6 Oct 2005, 1:32:40 UTC

Now David, You do realize that you have just upset the status quo for all BOINC projects. A major upgrade in less time then you set the expectation for, and no problems to be found? That is unheard of!!! Here I was expecting you to be down for at least 24 hours.

I don\'t know if this project can survive with everything running so smoothly. ;-)

(amazing job, can\'t find a problem anywhere.)

Team MacNN - The best Macintosh team ever.
ID: 1001 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile rbpeake

Send message
Joined: 25 Sep 05
Posts: 168
Credit: 246,593
RAC: 0
Message 1003 - Posted: 6 Oct 2005, 2:06:28 UTC - in response to Message 1001.  



I don\'t know if this project can survive with everything running so smoothly. ;-)

(amazing job, can\'t find a problem anywhere.)


You guys are amazing! :D
Regards,
Bob P.
ID: 1003 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Nuadormrac

Send message
Joined: 27 Sep 05
Posts: 37
Credit: 75,798
RAC: 0
Message 1004 - Posted: 6 Oct 2005, 3:01:56 UTC

A congrats is in order. Good job...
ID: 1004 · Rating: 1 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile David E K
Volunteer moderator
Project administrator
Project developer
Project scientist

Send message
Joined: 1 Jul 05
Posts: 985
Credit: 2,630,463
RAC: 1,248
Message 1008 - Posted: 6 Oct 2005, 4:11:48 UTC

It\'s mostly the product of the BOINC dev team and a little luck. I took cvs boinc, did the necessary upgrades to the server and database (did it on a test install on my laptop first), checked the site, crossed my fingers, started it up, and whola!
ID: 1008 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
AnRM
Avatar

Send message
Joined: 18 Sep 05
Posts: 123
Credit: 1,355,486
RAC: 0
Message 1012 - Posted: 6 Oct 2005, 5:51:50 UTC
Last modified: 6 Oct 2005, 5:52:23 UTC

Great going David......you guys are on a roll! Very impressive!(as is the whole project I might add:) Cheers, Rog.
ID: 1012 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Aaron Finney

Send message
Joined: 8 Oct 05
Posts: 52
Credit: 109,589
RAC: 0
Message 1118 - Posted: 8 Oct 2005, 18:26:40 UTC - in response to Message 1008.  

It's mostly the product of the BOINC dev team and a little luck. I took cvs boinc, did the necessary upgrades to the server and database (did it on a test install on my laptop first), checked the site, crossed my fingers, started it up, and whola!



Darn that pesky CVS tree!
ID: 1118 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
AnRM
Avatar

Send message
Joined: 18 Sep 05
Posts: 123
Credit: 1,355,486
RAC: 0
Message 1332 - Posted: 14 Oct 2005, 8:35:38 UTC
Last modified: 14 Oct 2005, 8:46:09 UTC

I have had about 6 or so random WU\'s stuck at 1% for hours since the upgrade. Prior to this, I had no errors for a few 100 WU\'s using BOINC 4.19. Since this has been a random problem not associated with any one box, the only thing common I can see is 4.19. Other threads have also mentioned this 1% problem. I will upgrade all my boxes to 5.2.1 to see if this helps. If there has been no change in in the WU\'s themselves, then the only change in the system has been the server upgrade and some incompatibility with 4.19.....if in fact 4.19 is the problem, it\'s time for Luddites like me to upgrade BOINC anyway. Cheers, Rog.
ID: 1332 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile sslickerson

Send message
Joined: 14 Oct 05
Posts: 101
Credit: 484,477
RAC: 0
Message 1352 - Posted: 14 Oct 2005, 18:17:18 UTC
Last modified: 14 Oct 2005, 18:30:30 UTC

I upgraded to 5.2.1 as well just before I attached to this project. This first 2 Wu both got stuck at 1% and I got rid of them after trying to restart and all that stuff. Shut down last night, downloaded 2 more today and so far the one WU running is also stuck at 1%, I\'ll give it a few hours, after that \"no new work\" until this is fixed.

Tim

Edit: Wu jumped to 8.33 after about 15 minutes...



ID: 1352 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
AnRM
Avatar

Send message
Joined: 18 Sep 05
Posts: 123
Credit: 1,355,486
RAC: 0
Message 1354 - Posted: 14 Oct 2005, 20:09:09 UTC
Last modified: 14 Oct 2005, 20:10:12 UTC

Thanks for the information, Tim. I have noticed that it does take a while for the WU to move off 1% ie. 5-10 mins depending on the speed of your system. The problems I have had on a random basis run for hours without any change...like the program goes into a loop somehow. Cheers, Rog.
ID: 1354 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile JimB
Avatar

Send message
Joined: 17 Sep 05
Posts: 19
Credit: 228,111
RAC: 0
Message 1516 - Posted: 19 Oct 2005, 14:29:10 UTC

Well, my 5.2.1 upgrade odyssey is mostly over. I upgraded from 4.45 and it just wouldn\'t work. It locked up requiring numerous hard reboots, and would not work with *my* Norton (I uninstalled Norton and installed ZoneAlarm Internet Suite). I finally uninstalled boinc and renamed boinc directory, did a fresh install of 5.2.1 and it seems to be stable now....

My question is what to do with all the wu\'s in the old directory? Delete? Copy over? I can\'t recall seeing this discussed, but may have missed it.


"Be all that you can be...considering." Harold Green
ID: 1516 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Mike Gelvin
Avatar

Send message
Joined: 7 Oct 05
Posts: 65
Credit: 10,612,039
RAC: 0
Message 1518 - Posted: 19 Oct 2005, 15:18:06 UTC - in response to Message 1516.  

Well, my 5.2.1 upgrade odyssey is mostly over. I upgraded from 4.45 and it just wouldn\'t work. It locked up requiring numerous hard reboots, and would not work with *my* Norton (I uninstalled Norton and installed ZoneAlarm Internet Suite). I finally uninstalled boinc and renamed boinc directory, did a fresh install of 5.2.1 and it seems to be stable now....

My question is what to do with all the wu\'s in the old directory? Delete? Copy over? I can\'t recall seeing this discussed, but may have missed it.

Unless your an expert with XML... I know of no automatic way to get those workunits into your current directory... you could try to copy over the XML and project files, but you risk also copying the problem.
ID: 1518 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Raithmir

Send message
Joined: 21 Sep 05
Posts: 5
Credit: 19,376
RAC: 0
Message 1536 - Posted: 20 Oct 2005, 10:30:44 UTC

Well I already posted this in the problems section but then noticed this thread.

Using BOINC 5.2.2 I can\'t attach to the project. I enter the URL, then my e-mail and password, but it tells me it can\'t find the account.

Any idea\'s?
ID: 1536 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Raithmir

Send message
Joined: 21 Sep 05
Posts: 5
Credit: 19,376
RAC: 0
Message 1539 - Posted: 20 Oct 2005, 12:41:27 UTC - in response to Message 1536.  
Last modified: 20 Oct 2005, 12:42:08 UTC

Well I already posted this in the problems section but then noticed this thread.

Using BOINC 5.2.2 I can\'t attach to the project. I enter the URL, then my e-mail and password, but it tells me it can\'t find the account.

Any idea\'s?


Worked fine using command line to attach via account key instead of e-mail/pass

C:\\Program Files\\BOINC>boinccmd.exe --project_attach http://boinc.bakerlab.org/rosetta <account key>

ID: 1539 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile JimB
Avatar

Send message
Joined: 17 Sep 05
Posts: 19
Credit: 228,111
RAC: 0
Message 1542 - Posted: 20 Oct 2005, 13:33:36 UTC - in response to Message 1536.  

Well I already posted this in the problems section but then noticed this thread.

Using BOINC 5.2.2 I can\'t attach to the project. I enter the URL, then my e-mail and password, but it tells me it can\'t find the account.

Any idea\'s?


You probably did, but did you use your account key instead of password?


"Be all that you can be...considering." Harold Green
ID: 1542 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Raithmir

Send message
Joined: 21 Sep 05
Posts: 5
Credit: 19,376
RAC: 0
Message 1546 - Posted: 20 Oct 2005, 15:28:04 UTC - in response to Message 1542.  

Well I already posted this in the problems section but then noticed this thread.

Using BOINC 5.2.2 I can\'t attach to the project. I enter the URL, then my e-mail and password, but it tells me it can\'t find the account.

Any idea\'s?


You probably did, but did you use your account key instead of password?


Tried both just in case but neither worked. I\'m attached ok though now and should report my first WU in a couple of hours. :)
ID: 1546 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote

Message boards : Number crunching : BOINC 5+ upgrade



©2017 University of Washington
http://www.bakerlab.org